Wikia

Sonic News Network

MediaWiki Upgrade Bug List

8,431pages on
this wiki

Forum page

This Forum has been archived

Visit the new Forums
Forums: Index > Questions > MediaWiki Upgrade Bug List

I see that MediaWiki has been upgraded. As one will most likely encounter bugs, I have started a bug list to keep track of them. Please report any bugs or errors or difficulties concerning the upgrade here. Trak Nar Ramble on 05:17, July 17, 2012 (UTC)

Bug Reports

Please list any bugs you encounter here.

[DEV] AJAX Recent Changes

  • Recent Changes will not group and hide multiple edits. It works fine until the AJAX update, and then the blue triangles that signify a group of changes and is used to expand/collapse them disappears. All the grouped changes are then listed in the log and there is no way to hide them. Now, we had this same problem on Wookieepedia. This is a dev.wikia.com script and both Wookieepedia and Fallout Wiki have fixes, which can be applied to this wiki. Trak Nar Ramble on 05:17, July 17, 2012 (UTC)
    • AJAX isn't even loading now. RCs won't auto-refresh. I think it may pertain to the humongous grouped edit that is currently in the log. Trak Nar Ramble on 09:51, July 17, 2012 (UTC)
      • Nevermind, the error resolved itself. Still mentioning it, however, as it may be the java screwing up because the grouped edits on the Adminship page are massive. Trak Nar Ramble on 10:03, July 17, 2012 (UTC)
        • Wikia Update: I have asked the maintainers of the script at Dev Wiki to look into this issue, but unfortunately their lead developer is on vacation so it may be a few more days. I believe the issue stems from some changed MediaWiki classes and methods from 1.16->1.19. --daNASCAT @Wikia 23:27, July 18, 2012 (UTC)

[DEV] AJAX WikiActivity

Sometimes refuses to appear, and glitches when trying to load more edits at the bottom. --Bullet Francisco (talk) Contributions Editcount 10:43, July 17, 2012 (UTC)

  • Wikia Update: I have asked the maintainers of the script at Dev Wiki to look into this issue, but unfortunately their lead developer is on vacation so it may be a few more days. I believe the issue stems from some changed MediaWiki classes and methods from 1.16->1.19. --daNASCAT @Wikia 23:27, July 18, 2012 (UTC)

[INTERMITTENT/RESOLVED] AJAX button missing in Monobook

The AJAX checkbox on the Recent Changes is missing. Multiple refreshes and dismissing the site notice have not caused it to reappear. Was it accidentally disabled? Can it be enabled again? I much prefer to have the RCs update automatically, rather than refresh the page manually. You can see a screenshot of the missing button here, along with a CSS error that is mentioned below. Trak Nar Ramble on 03:02, July 26, 2012 (UTC)

  • Update: I just checked on this and this is a bug that exists only in Monobook. How soon can this be fixed? Trak Nar Ramble on 02:49, August 1, 2012 (UTC)

[RESOLVED?] Staggered deletion log in Recent Changes

RecentChangesAlignment

Behold! Behold and despair!

As you can see from the screenshot to the right, the deletion log in the Recent Changes is staggered. I only see this happening when blogs are being deleted. What is causing this error? It was quite shocking to behold and for a moment, I thought that there was a serious vandal or hacker attack before I realized that it was a very nasty bug. Trak Nar Ramble on 09:19, July 28, 2012 (UTC)

[CONFIRMED/RESOLVED] Follow/Unfollow buttons

  • This is a Monobook-only glitch. When I click the "Follow" tab, it goes to "Following..." but never refreshes. After I refresh the page, does the change go through. Trak Nar Ramble on 05:17, July 17, 2012 (UTC)
    • Wikia Update: Thanks for the extra updates, we have gone ahead and confirmed the bug is now happening on Monobook in all skins and a bug ticket has been opened. --daNASCAT @Wikia 23:25, July 18, 2012 (UTC)
      • The Follow/Unfollow bug seems to have been resolved. I haven't had a problem as of late. Trak Nar Ramble on 04:49, July 27, 2012 (UTC)

[INTERMITTENT] Categorizing in WikiActivity

For any forum, userpage, project, or any other page with a category, WikiActivity is saying that a user is adding that category for every edit, when they are not. --Bullet Francisco (talk) Contributions Editcount 10:40, July 17, 2012 (UTC)

I have also had this probleme. I have also had the same probleme at the ACSFW. Will Life Icon Will Rose Will Life Icon 08:23, July 18, 2012 (UTC)
    • Wikia Update: I can't reproduce this issue, could you be kind enough to give me a screenshot of the issue so I can more easily verify exactly what and where the bug is? --daNASCAT @Wikia 23:37, July 18, 2012 (UTC)

[CONFIRMED/RESOLVED] Blog comment editor not loading

  • This may be a Monobook-only issue, but when I go to comment on a blog, it says "Loading Editor" and just gets stuck on that screen. I can still type the comment while the "Loading Editor" text displays, but I can't post it. I've refreshed the page after typing, refreshed the page before typing, even just left the page sit and finish loading. It. Won't. Load. Thus, since I am a Monobook user and refuse to switch to Oasis for a blog, I cannot comment. Trak Nar Ramble on 07:54, July 18, 2012 (UTC)
    • I am also experiencing this same problem. Not only can I not make any comments on blogs (I primarily use Monobook. I have yet to see for myself if the problem exists in Oasis as well), I can't disable blog comments either. Instead I get a screen that shows that there's a problem going on with Wikia's server and that I should "try again later". I'm not sure if the two problems are related, but since this other problem involves blogs I feel that it at least deserves a mention. Lloyd the Cat"I don't die. I just go on adventures." 08:07, July 18, 2012 (UTC)
      • Wikia Update: Confirmed that the Mini-Editor for Blog Comments is not working in the Monobook skin. A bug ticket has been filed. --daNASCAT @Wikia 23:49, July 18, 2012 (UTC)
        • Alright, I've encountered another problem. In order to reply to blogs, I tack on "?useskin=wikia" at the end. It worked once. I did it again, and now the editor won't load, even though I am using the Oasis skin. I have it open in another tab right now, using the Oasis skin in that tab, and I'm watching it say "Loading editor" without actually loading the editor. So, it's at least intermittently broken in Oasis as well. Trak Nar Ramble on 10:07, July 25, 2012 (UTC)

Update: Things seem to be in working order again. Trak Nar Ramble on 10:17, August 3, 2012 (UTC)

Userpage glitch

Glitch

Weird userpage glitch where the cut-off for wide userpages extends beyond where it should. --Bullet Francisco (talk) Contributions Editcount 12:30, July 18, 2012 (UTC)

I'm sorry, but your screenshot confuses me. I think you zoomed out so far it's hard for me to tell where exactly the bug is because it gets all scrunched together when you're that zoomed out. Can you explain what you mean by "cut-off" and give me a link to a page this is happening to you on? --daNASCAT @Wikia 23:44, July 18, 2012 (UTC)
On User:Genesjs, it cuts off the userpage for being too wide (as it is supposed to), however, the cut off zig zag line goes beyond where it is supposed to. --Bullet Francisco (talk) Contributions Editcount 23:47, July 18, 2012 (UTC)
That actually looks fine to me because the entire page is in one table. It's supposed to be on a table-by-table basis. --daNASCAT @Wikia 23:51, July 18, 2012 (UTC)
I took a look, and your userpage works fine on my end, Gen. Could this possibly be an Oasis-only issue? I'm using Monobook, and I don't notice a difference in width. Trak Nar Ramble on 06:45, July 19, 2012 (UTC)
It's a Oasis-Only issue. Look at the very bottom of the screenshot, there is a white zig zag line extending beyond where it is supposed to. --Bullet Francisco (talk) Contributions Editcount 08:47, July 20, 2012 (UTC)
I just happende to stumble upon this moments ago. The Zig-Zag goes through the background as showed in the image. Willaca (talk) 08:49, July 20, 2012 (UTC)
WikiaUserGlitch

Another example of the glitch has been posted. --Bullet Francisco (talk) Contributions Editcount 08:53, July 20, 2012 (UTC)

Oasis Toolbar and Edit Button glitch

The Oasis Toolbar on the bottom of the screen sometimes glitches and doesn't follow as the user scrolls, and when you try and hover over "My Tools" it often glitches and refuses to load. Same goes for the "Edit" button arrow that gives you the option to see the history and such. --Bullet Francisco (talk) Contributions Editcount 12:32, July 18, 2012 (UTC)

  • Wikia Update: If you have any way to screenshot or screencast this happening to you that would be useful as this is honestly the first I've heard of it from any 1.19 wiki. --daNASCAT @Wikia 23:49, July 18, 2012 (UTC)
WikiaGlitch2

[NON-ISSUE] Blog Facial Glitch

Let's say your making a comment on a blog with a facial expression (Like :) or :@). And when you do it it shows the letter (if the facial has a letter) and moves it to the center. It also removes the ":" if they are a part of the Facial. Here's a screenshot on my recent blog. Will Life Icon Will Rose Will Life Icon 07:39, July 19, 2012 (UTC)
Gltich248

Look myn and Fira's comment. We both were making the ":P" Facial. But it just shows the letter "P"

  • That's because the colon is used to indent. If it's not preceded by a word or something, it will just indent the P. Like so:
P
  • Try using the "nowiki" tags and see if that solves the problem. Trak Nar Ramble on 07:46, July 19, 2012 (UTC)

[RESOLVED] New Messages Glitch

I'm not sure if this is present in Oasis as well, but when I recieve new messages on the Wiki I'm currently visiting (in this case, this Wiki) instead of getting "You have new messages (recent changes)" I get "You have new messages on Sonic News Network", and when I click the only present link it just takes me right to my talk page instead of giving me the option to look at the new changes like I would if I clicked "(recent changes)". I thought this would go away within a couple of days since it first recently appeared, but since it hasn't I was hoping that someone would be willing to look into this. Lloyd the Cat"I don't die. I just go on adventures." 09:11, July 19, 2012 (UTC)

[STILL EXISTS] Edit conflict bug

I just stumbled upon this here, too. I was replying to a thread and got an edit conflict. In the bottom where my text was supposed to be was the text from the edit that conflicted me. My text was nowhere to be found. Not even a difference was shown. So, I had to hit "Back" and copy my edit. Trak Nar Ramble on 05:59, July 20, 2012 (UTC)

I have had this issue as well. --Bullet Francisco (talk) Contributions Editcount 08:53, July 20, 2012 (UTC)
I haven't had a edit conflict in a while. But when I do and this glitch happendes. I'll tell you guys. Willaca (talk) 09:06, July 20, 2012 (UTC)
DiscoDuck experienced this on the RfA, as shown on FreeSmudger's nomination. --Bullet Francisco (talk) Contributions Editcount 09:09, July 20, 2012 (UTC)
Those links don't give us much help. Willaca (talk) 09:17, July 20, 2012 (UTC)

I've seen this one a couple of times. -- Supermorff (talk) 16:45, July 20, 2012 (UTC)

[RESOLVED] Wiki Advertisements Glitch?

One thing I've noticed (not sure if it's also present in Oasis) is that the 3 random pictures that advertise random Wikis that appear on the very bottom of the page have seem to have shifted to the left corner. Something tells me this is indeed a glitch, but I can't say for sure. If anyone needs me to upload a screenshot then feel free to ask. Lloyd the Cat"I don't die. I just go on adventures." 07:35, July 20, 2012 (UTC)

  • I don't see it on my end (in fact, the Wikia Spotlights simply do not load at all), but other people have noticed the same problem on Wookieepedia. Checking a random page there, I don't see any of those Wikia Spotlight ads. If not seeing them at all is a bug, I'm mentioning it. Not sure why I've never noticed this before. o.O Trak Nar Ramble on 07:40, July 20, 2012 (UTC)
  • I haven't seen it. Will Life Icon Will Rose Will Life Icon 07:54, July 20, 2012 (UTC)
WikiaGlitch

[RESOLVED] Deleted Files in Unused Files

As seen in Special:UnusedFiles, three deleted files including File:Knuckles.gif appear. They were deleted, and shouldn't appear. --Bullet Francisco (talk) Contributions Editcount 08:57, July 20, 2012 (UTC)

  • We have this exact same problem on Wookieepedia. Trak Nar Ramble on 09:12, July 20, 2012 (UTC)
    • That's unfortunate. Apparently, the above Ad alignment problem and the below editcount problem are present there as well. --Bullet Francisco (talk) Contributions Editcount 09:14, July 20, 2012 (UTC)
      • Perhaps I should just copy the Wook's bug list over here to save us some time? :P Trak Nar Ramble on 09:16, July 20, 2012 (UTC)
        • Maybe, most of the "[CONFIRMED]" ones are here. Might want to confirm they are here, first. --Bullet Francisco (talk) Contributions Editcount 09:22, July 20, 2012 (UTC)
          • The [CONFIRMED] tag just means that the bug was confirmed by Wikia and a bug report was filed. I started using the same tags here to keep track of the bug reports as they were dealt with, like [DEV] for bugs that have something to do with the dev.wikia.com script and such. But, yeah, checking to see if the same bugs there are the same here before reporting them would work, as who knows? Perhaps there was something that was fixed. I haven't encountered any searchbox woes as we reported there, so that was taken care of before the upgrade was applied here. Trak Nar Ramble on 09:29, July 20, 2012 (UTC)

[RESOLVED] Editcount glitch

I was switching between two users' editcount (Fly the Fox, and FreeSmudger, for the record) and noticed when I went to type in the latter's name into the search bar, it stayed on Fly the Fox's editcount. I attempted this with two other users (Supermorff and Myself 123, for the record), and it still refused to work. Possible glitch? --Bullet Francisco (talk) Contributions Editcount 09:00, July 20, 2012 (UTC)

Yep. I to have had the problem. I just tested. Willaca (talk) 09:20, July 20, 2012 (UTC)

[INTERMITTENT] WikiActivity Disappearing?

Doesn'tLoad

As shown in the screenshot, nothing appeared. I've had this happen a couple times. --Bullet Francisco (talk) Contributions Editcount 09:19, July 20, 2012 (UTC)

I'm not sure Bullet.This has happend numerous times in the past. Willaca (talk) 09:31, July 20, 2012 (UTC)

But still a glitch nonetheless. In those screenshots had a few edits leftover, this glitch has no edits whatsoever. There is really nothing to "not be sure" about. --Bullet Francisco (talk) Contributions Editcount 09:34, July 20, 2012 (UTC)
Okay then. Willaca (talk) 09:36, July 20, 2012 (UTC)

I have high doubts this is a glitch, as by observing the Recent Changes section (which also has the same "glitch/feature"), all recent activity will disappear, but observe the section of time where the last edit was made. This time goes up to 24:00, where it will literally start "the next day" of the wikipedia. Thus, all previous information might need to be cleared out to save space for newer edits. Serious Sam Minigun icon Heavy 10:17, July 20, 2012 (UTC)

This happened a little after 4:00 EST (which is when I saved the image). --Bullet Francisco (talk) Contributions Editcount 10:20, July 20, 2012 (UTC)
Well, it could perhaps occur due to the size of our wiki. On smaller wikis, I don't think I've seen this problem. Serious Sam Minigun icon Heavy 10:35, July 20, 2012 (UTC)
That's probably still be a glitch, as it shouldn't happen. --Bullet Francisco (talk) Contributions Editcount 10:37, July 20, 2012 (UTC)

[RESOLVED] RecentChanges Bug

Some of the RecentChanges buttons aren't there on MonoBook. The Grouped RecentChanges one and the Show Logs one aren't appearing, and instead says "(&)lt;r(&)gt;". (Got from Wookiepedia, checked, and copied onto here) --Bullet Francisco (talk) Contributions Editcount 09:24, July 20, 2012 (UTC)

This happens in Wikia skin too. -- Supermorff (talk) 16:45, July 20, 2012 (UTC)

Picture Glitch

I'm not too sure if this is a problem on my end or on wikia's end, or if this even has to do with MediaWiki (although it probably does) I've noticed that when you edit a page, if you search for pictures via the "Photo" button, it will say you have X number of results, but when you click to see the next page of results, it says you have 0 results and all you can see is the blank page of photos. The Fresh Prince of Grooseland 15:35, July 20, 2012 (UTC)

Sortable tables

The sorting buttons on the sortable table on Sonic News Network:Editcount have disappeared. -- Supermorff (talk) 09:18, July 21, 2012 (UTC)

This is still an issue. -- Supermorff (talk) 19:46, February 17, 2013 (UTC)

[WORKS FOR ME/RESOLVED]Link suggestions

The link suggestions now list below the edit window... and not even consistently. Sometimes, they will not work at all. I rather miss the old format, where they'd be listed in a box right there while you're typing out a link... It was mentioned on Wookieepedia that this problem was being looked into. Has there been any progress made on resolving this issue? Trak Nar Ramble on 04:47, July 22, 2012 (UTC)

  • Now the link suggestions have stopped working completely. :| Trak Nar Ramble on 08:19, July 26, 2012 (UTC)

Update: The link suggestions are working on my end. Trak Nar Ramble on 10:17, August 3, 2012 (UTC)

[INTERMITTENT] Monobook CSS glitch

MonobookCSSGlitch

Monobook CSS glitch

Monobook glitched. It didn't load the background or logo, so I assume that it is a CSS error. I have provided a screenshot of the error. This hasn't happened before, so I labeled it as intermittent. After a refresh, the error resolved itself anyway. Trak Nar Ramble on 04:31, July 26, 2012 (UTC)

[CONFIRMED/RESOLVED] File bug

File bug

File bug

I recently encountered a bug with File:GE8958.jpg. When I tried to categorize the file, this message appeared: "The modification you tried to make was aborted by an extension hook".

When I tried to categorize it by editing its file page, this message appeared: "The database did not find the text of a page that it should have found, named "File:GE8958.jpg" (revision#: 0). This is usually caused by following an outdated diff or history link to a page that has been deleted. If this is not the case, you may have found a bug in the software. Please report this to Wikia staff, making note of the URL."

I've so far only encountered this bug on this file. If I find this bug on other files, I will list them here.   ★EYCEST★R★    ★Contact★ 01:32, July 30, 2012 (UTC)

Make sure you report it to Wikia staff too, using Special:Contact. -- Supermorff (talk) 18:27, July 30, 2012 (UTC)
Thanks for the reminder. I just sent them an email.   ★EYCEST★R★    ★Contact★ 18:46, July 30, 2012 (UTC)

[RESOLVED] Related Changes

This might not be due to the MediaWiki upgrade as it's the first time I have used this special page in a while, but Special:RecentChangesLinked is not working for me at all. Nothing is showing up, even when I know for a fact that something should show up. -- Supermorff (talk) 12:05, August 9, 2012 (UTC)

It's working now. -- Supermorff (talk) 19:45, February 17, 2013 (UTC)

Discussion

Aren't MediaWiki upgrades just wonderful? :P Trak Nar Ramble on 05:17, July 17, 2012 (UTC)

Uhh, I had something that I think might be something sue to the MediaWiki upgrade. A dew weeks ago my edits was I think "1003". And then the next day it was "999" I think. Either this or my edits where reverted (which is most un-likely cause those extra edits to 1000 where blog comments". Will Life Icon Will Rose Will Life Icon 09:54, July 17, 2012 (UTC)

  • Reverted edits still count toward your edit count as they're logged. However, if comments were deleted, then that would be a reason for the missing edits. Do you know what blog it was? Checking the deletion log should reveal where they went. However, if they were not as a result of deletion, then that would definitely be a bug. Trak Nar Ramble on 10:02, July 17, 2012 (UTC)
  • @Trak No the Blog wasn't deleted. It was one of Murphy's comics. Will Life Icon Will Rose Will Life Icon 10:10, July 17, 2012 (UTC)
    • If anything you edited was deleted, your edits get removed. --Bullet Francisco (talk) Contributions Editcount 10:11, July 17, 2012 (UTC)
      • Mabey it was and mabey it wasn't. :P I can't remember. It's been a while since I "re-visited" the blog. Will Life Icon Will Rose Will Life Icon 10:13, July 17, 2012 (UTC)
  • I have contacted Wikia and gave them the link to this topic. Hopefully these issues will be resolved soon. Trak Nar Ramble on 08:00, July 18, 2012 (UTC)
    • And we replied! I am now following this page, thanks for having this all in one succinct place! --daNASCAT @Wikia 23:49, July 18, 2012 (UTC)
      • Thank you! You've given Wookieepedia hope and you're giving SNN hope. :) Trak Nar Ramble on 03:01, July 19, 2012 (UTC)

Around Wikia's network

Random Wiki